X-Git-Url: https://git.saurik.com/apt.git/blobdiff_plain/478707e015972cd3efea32059c97b13508705a26..947878508fbd153766a9ded131a04260ca4c7a83:/debian/apt.postinst

diff --git a/debian/apt.postinst b/debian/apt.postinst
index 88fb932df..4d87c4e25 100644
--- a/debian/apt.postinst
+++ b/debian/apt.postinst
@@ -15,13 +15,12 @@ set -e
 
 case "$1" in
     configure)
-
-        if ! test -f /etc/apt/trusted.gpg; then
-                cp /usr/share/apt/debian-archive.gpg /etc/apt/trusted.gpg
-        fi
-
+	SECRING='/etc/apt/secring.gpg'
+	# test if secring is an empty normal file
+	if test -f $SECRING -a ! -s $SECRING; then
+		rm -f $SECRING
+	fi
 	apt-key update
-
     ;;
 
     abort-upgrade|abort-remove|abort-deconfigure)