]> git.saurik.com Git - apt.git/blobdiff - debian/rules
report progress for removing while purging pkgs
[apt.git] / debian / rules
index f4f7ec06bd803413137cca5deaf0a836d36f392e..18b3f34f3085c859ef9947a5200461bfc5c9bfe3 100755 (executable)
@@ -9,6 +9,7 @@ export NOISY=1
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+export PARALLEL = $(or $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))),1)
 
 # FOR AUTOCONF 2.52 AND NEWER ONLY
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
@@ -17,13 +18,19 @@ else
   confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
 endif
 
+# Set the number of procs to be run in parallel from the options.
+confflags += --with-procs=$(PARALLEL)
+
 # See below
 -include build/environment.mak
 
 ifneq (,$(shell which dpkg-buildflags))
-  export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
-  export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
-  export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+  # make does not export to $(shell) so we need to workaround 
+  # (http://savannah.gnu.org/bugs/?10593)
+  dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
+  export CXXFLAGS = $(shell $(dpkg_buildflags) --get CXXFLAGS)
+  export LDFLAGS = $(shell $(dpkg_buildflags) --get LDFLAGS)
+  export CPPFLAGS = $(shell $(dpkg_buildflags) --get CPPFLAGS)
 else
   ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
     export CXXFLAGS = -O0 -g -Wall
@@ -35,23 +42,14 @@ endif
 # Default rule
 build:
 
-PKG=apt
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-
 # Determine the build directory to use
-BASE=.
-ifdef BUILD
-BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
-else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
-endif
-BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
-BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
-override BLD := $(BUILDX)
+override BASE := .
+override BLD := $(BASE)/build
 
-ifeq ($(words $(BLD)),0)
-override BLD := ./build
-endif
+# When building without <nocheck>, the header is available and thus the test is
+# successful. When building with <nocheck>, the header is missing, but we still
+# pretend it to be available, because configure would fail otherwise.
+export ac_cv_header_gtest_gtest_h=yes
 
 # APT Programs in apt-utils
 APT_UTILS=ftparchive sortpkgs extracttemplates
@@ -70,7 +68,7 @@ LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
 build-binary: build/build-binary-stamp
-build-debiandoc: build/build-debiandoc-stamp
+build-docbook: build/build-docbook-stamp
 build-manpages: build/build-manpages-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
@@ -82,7 +80,7 @@ build/environment.mak: build/configure-stamp
 configure: configure.ac
 build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
        dh_testdir
-       -mkdir build
+       mkdir -p build
        cp COPYING debian/copyright
        cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
        touch $@
@@ -101,9 +99,9 @@ else
 endif
        touch $@
 
-build/build-debiandoc-stamp: build/configure-stamp
+build/build-docbook-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE) debiandoc
+       $(MAKE) docbook
        touch $@
 
 build/build-manpages-stamp: build/configure-stamp
@@ -126,7 +124,7 @@ debian/%.install: debian/%.install.in
        sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
 
 # Build architecture-independent files here.
-libapt-pkg-doc: build-debiandoc
+libapt-pkg-doc: build-docbook
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -134,25 +132,20 @@ libapt-pkg-doc: build-debiandoc
 #
 # libapt-pkg-doc install
 #
-       dh_installdocs -p$@ $(BLD)/docs/design* \
-                           $(BLD)/docs/dpkg-tech* \
-                           $(BLD)/docs/files* \
-                           $(BLD)/docs/method* \
-                           doc/libapt-pkg2_to_3.txt \
-                           doc/style.txt \
-                           $(BLD)/doc/doxygen/html
+       rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
+       dh_installdocs -p$@
        dh_installexamples -p$@
-
+       dh_lintian -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
-       dh_compress -p$@
+       dh_compress -p$@ -X.xhtml
        dh_fixperms -p$@
        dh_installdeb -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-doc: build-debiandoc
+apt-doc: build-docbook
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -160,10 +153,7 @@ apt-doc: build-debiandoc
 # apt-doc install
 #
        # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text \
-                           $(BLD)/docs/guide*.html \
-                           $(BLD)/docs/offline*.text \
-                           $(BLD)/docs/offline*.html
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -188,6 +178,8 @@ apt: build-binary build-manpages debian/apt.install
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
        cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
        chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
+       # install vendor specific apt confs
+       find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
@@ -197,7 +189,9 @@ apt: build-binary build-manpages debian/apt.install
        dh_install -p$@ --sourcedir=$(BLD)
 
        # Remove the bits that are in apt-utils
-       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver internal-planner)
+       cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+       ln -s ../solvers/dump debian/$@/usr/lib/apt/planners/dump
 
        # https has its own package
        rm debian/$@/usr/lib/apt/methods/https
@@ -206,17 +200,25 @@ apt: build-binary build-manpages debian/apt.install
        #mv debian/$@/usr/bin/apt-report-mirror-failure \
        #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
+       # move the apt-helper in place
+       mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+       # install apt.systemd.daily helper in the right place
+       install -m755 debian/apt.systemd.daily debian/$@/usr/lib/apt/
+
        dh_bugfiles -p$@
        dh_lintian -p$@
-       dh_installexamples -p$@ $(BLD)/docs/examples/*
+       dh_installexamples -p$@
        dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
-       dh_installcron -p$@
+       dh_installcron -p$@ --name=apt-compat
+       dh_systemd_enable -p$@ apt-daily.timer
+       dh_systemd_start -p$@ apt-daily.timer
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_installlogrotate -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -p$@
        dh_installdeb -p$@
        dh_shlibdeps -p$@
        dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
@@ -250,8 +252,8 @@ apt-utils: build-binary build-manpages
        dh_installdirs -p$@
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
-       cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
        cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
+       cp $(BLD)/bin/apt-internal-planner debian/$@/usr/lib/apt/planners/apt
 
        dh_install -p$@ --sourcedir=$(BLD)
        dh_link -p$@
@@ -305,7 +307,7 @@ $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
        dh_fixperms -p$@
        dh_makeshlibs -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ 
+       dh_shlibdeps -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -317,7 +319,7 @@ apt-transport-https: build-binary libapt-pkg-dev
        dh_installdirs -p$@
 
        dh_install -p$@ --sourcedir=$(BLD)
-       dh_installdocs -p$@ debian/apt-transport-https.README
+       dh_installdocs -p$@
        dh_installexamples -p$@
 
        # Install the man pages..
@@ -328,7 +330,7 @@ apt-transport-https: build-binary libapt-pkg-dev
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ 
+       dh_shlibdeps -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -344,7 +346,7 @@ binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-trans
 binary-indep: apt-doc libapt-pkg-doc
 binary: binary-indep binary-arch
 build-arch: build-binary
-build-indep: build-manpages build-debiandoc
+build-indep: build-manpages build-docbook
 build: build-indep build-arch
 
 .PHONY: build clean binary-indep binary-arch binary