projects
/
apt.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
centralize unlink checks in acquire-item
[apt.git]
/
debian
/
apt.postinst
diff --git
a/debian/apt.postinst
b/debian/apt.postinst
index b0a5da7d85d7cb5c5ba46c65a15b63fc83be6f0c..1f98fcece4bad4d0b82e9edc7d7b78dc9c6c243b 100755
(executable)
--- a/
debian/apt.postinst
+++ b/
debian/apt.postinst
@@
-40,9
+40,14
@@
case "$1" in
fi
# add unprivileged user for the apt methods
fi
# add unprivileged user for the apt methods
- adduser --force-badname --system -
home /var/empty
\
+ adduser --force-badname --system -
-home /nonexistent
\
--no-create-home --quiet _apt || true
--no-create-home --quiet _apt || true
+ # Fixup any mistake in the home directory of the _apt user
+ if dpkg --compare-versions "$2" lt-nl 1.1~exp10~; then
+ usermod --home /nonexistent _apt
+ fi
+
# deal with upgrades from experimental
if dpkg --compare-versions "$2" 'eq' '1.1~exp3'; then
# libapt will setup partial/ at runtime
# deal with upgrades from experimental
if dpkg --compare-versions "$2" 'eq' '1.1~exp3'; then
# libapt will setup partial/ at runtime