]> git.saurik.com Git - apt.git/blobdiff - debian/rules
more tweaking to debian/rules. Added target 'cvs-mkul'...
[apt.git] / debian / rules
index c2b55f97dba6e3ba1226787d850180e2c2f699d6..00bcc60e4fb584b1c588b9bb460df38e98034325 100755 (executable)
@@ -2,7 +2,15 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.10 1999/03/18 03:30:31 doogie Exp $
+# $Id: rules,v 1.12 1999/03/21 13:24:35 doogie Exp $
+
+
+# For the deb builder, you can run 'debian/rules cvs-build', which does all
+# steps nescessary to produce a proper source tarball with the CVS/ removed.
+# It builds in debian/cvs-build/apt-<VER>/, and places files in
+# debian/cvs-build/.  Optionally, you can run 'debian/rules cvs-mkul' to
+# create ../upload-<VER>, with all the files needed to be uploaded placed
+# in it.
 
 DEB_BUILD_PROG:=debuild
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
@@ -20,7 +28,11 @@ endif
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
-export LIBAPT_MAJOR=`egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2`
+export LIBAPT_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
+#debian/shlibs.local:
+#      rm -f $@
+#      echo "libapt-pkg $(LIBAPT_MAJOR) libapt-pkg$(LIBAPT_MAJOR)" >> $@
+#      echo "libapt-pkg $(LIBAPT_MAJOR) apt $(APT_DEBVER)" >> $@
 
 build: build-stamp
 build-stamp: configure
@@ -46,45 +58,46 @@ clean:
        -$(MAKE) distclean
        dh_clean
 
+binary-indep: libapt-pkg-doc
 # Build architecture-independent files here.
-binary-indep: build
-       dh_testdir -i
-       dh_testroot -i
-       dh_clean -i -k
-       dh_installdirs -i
+libapt-pkg-doc: build debian/shlibs.local
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+       dh_installdirs -p$@
 #
 # libapt-pkg-doc install
 #
-
        cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
          build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
        cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-       dh_installdocs -i
-       dh_installexamples -i
-#      dh_installmenu -i
-#      dh_installinit -i
-#      dh_installcron -i
-       dh_installmanpages -i
-
-#      dh_undocumented -i
-       dh_installchangelogs -i
-       dh_strip -i
-       dh_compress -i
-       dh_fixperms -i
-#      dh_suidregister -i
-       dh_installdeb -i
-       dh_gencontrol -i -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
-       dh_md5sums -i
-       dh_builddeb -i
+       dh_installdocs -p$@
+       dh_installexamples -p$@
+#      dh_installmenu -p$@
+#      dh_installinit -p$@
+#      dh_installcron -p$@
+       dh_installmanpages -p$@
+
+#      dh_undocumented -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+#      dh_suidregister -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+       dh_md5sums -p$@
+       dh_builddeb -p$@
 
 
 # Build architecture-dependent files here.
-binary-arch: build
-       dh_testdir -a
-       dh_testroot -a
-       dh_clean -a -k
-       dh_installdirs -a
 
+binary-arch: apt libapt-pkg-dev
+apt: build debian/shlibs.local
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+       dh_installdirs -p$@
 #
 # apt install
 #
@@ -111,32 +124,54 @@ binary-arch: build
        
 #      head -n 500 ChangeLog > debian/ChangeLog
 
-#
-# libapt-pkg-dev install
-#
-       ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
-       cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
 
 
-       dh_installdocs -a
+       dh_installdocs -p$@
        dh_installexamples -papt build/docs/examples/*
 #      dh_installmenu -papt
 #      dh_installinit -papt
 #      dh_installcron -papt
-       dh_installmanpages -a
+       dh_installmanpages -p$@
 
 #      dh_undocumented -papt
-       dh_installchangelogs -a
-       dh_strip -a
-       dh_compress -a
-       dh_fixperms -a
-#      dh_suidregister -a
-       dh_installdeb -a
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+#      dh_suidregister -p$@
+       dh_installdeb -p$@
        LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
-       dh_gencontrol -a -u-Vlibapt-pkg:major=${LIBAPT_MAJOR}
+       dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
        dh_makeshlibs -m${LIBAPT_MAJOR} -Vlibapt-pkg${LIBAPT_MAJOR} -papt
-       dh_md5sums -a
-       dh_builddeb -a
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+libapt-pkg-dev: build debian/shlibs.local
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+       dh_installdirs -p$@
+#
+# libapt-pkg-dev install
+#
+       ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
+       cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
+
+       dh_installdocs -p$@
+#      dh_installmenu -papt
+#      dh_installinit -papt
+#      dh_installcron -papt
+       dh_installmanpages -p$@
+
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+#      dh_suidregister -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+       dh_md5sums -p$@
+       dh_builddeb -p$@
 
 source diff:                                                                  
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
@@ -161,7 +196,7 @@ really-clean: clean
        rm -f l33ch-stamp
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
 
 
 # Done by the uploader.
@@ -175,9 +210,14 @@ cvs-build:
        rm -rf debian/cvs-build
        cvs update
        buildlib/mkChangeLog
+       make startup
        make doc
        tar c --exclude CVS --exclude debian/cvs-build . |\
                (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
 # The next line isn't needed, as debuild will make the .tar.gz for us.
 #      (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
-       (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG) -us -uc)
+       (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
+
+cvs-mkul:
+       -mkdir -p ../upload-$(APT_DEBVER)
+       cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)