export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-# apt can be build from the same source on debian and ubuntu
-DIST = $(shell lsb_release -i -s)
-
# FOR AUTOCONF 2.52 AND NEWER ONLY
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build $(DEB_HOST_GNU_TYPE)
cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
touch $@
-build/build-stamp: build/configure-stamp patch
+build/build-stamp: build/configure-stamp
# Add here commands to compile the package.
$(MAKE) binary
touch $@
$(MAKE) doc
touch $@
-clean: unpatch
+clean:
dh_testdir
# dh_testroot
-$(MAKE) clean
cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
dh_installdocs -p$@
+ dh_installexamples -p$@
# Install the man pages..
dh_installman -p$@
-mkdir -p ../upload-$(APT_DEBVER)
cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
-patch: patch-stamp
-patch-stamp:
- cp debian/patches/00list.$(DIST) debian/patches/00list
- dpatch apply-all
- touch patch-stamp
-
-unpatch:
- cp debian/patches/00list.$(DIST) debian/patches/00list
- dpatch deapply-all
- rm -rf patch-stamp debian/patched
-
arch-build:
rm -rf debian/arch-build
mkdir -p debian/arch-build/apt-$(APT_DEBVER)