]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* apt-pkg/acquire-item.cc:
[apt.git] / debian / rules
index 0787c0c8b8a515645c38b4f3d90492dc57fd9db3..02ee734bb24c71580e82583cabb8bb7de755ed96 100755 (executable)
@@ -17,9 +17,6 @@
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-# apt can be build from the same source on debian and ubuntu
-DIST = $(shell lsb_release -i -s)
-
 # FOR AUTOCONF 2.52 AND NEWER ONLY
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
   confflags += --build $(DEB_HOST_GNU_TYPE)
@@ -39,8 +36,9 @@ endif
 # Default rule
 build:
 
+PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -114,7 +112,7 @@ build/configure-stamp: configure
        cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
        touch $@
 
-build/build-stamp: build/configure-stamp patch
+build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
        $(MAKE) binary
        touch $@
@@ -124,7 +122,7 @@ build/build-doc-stamp: build/configure-stamp
        $(MAKE) doc
        touch $@
 
-clean: unpatch
+clean:
        dh_testdir
 #      dh_testroot
        -$(MAKE) clean
@@ -272,6 +270,7 @@ apt-utils: build debian/shlibs.local
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        dh_installdocs -p$@
+       dh_installexamples -p$@
 
        # Install the man pages..
        dh_installman -p$@
@@ -334,20 +333,9 @@ cvs-mkul:
        -mkdir -p ../upload-$(APT_DEBVER)
        cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
 
-patch: patch-stamp
-patch-stamp:
-       cp debian/patches/00list.$(DIST) debian/patches/00list
-       dpatch apply-all
-       touch patch-stamp
-
-unpatch:
-       cp debian/patches/00list.$(DIST) debian/patches/00list
-       dpatch deapply-all
-       rm -rf patch-stamp debian/patched
-
 arch-build:
        rm -rf debian/arch-build
        mkdir -p debian/arch-build/apt-$(APT_DEBVER)
-       baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+       tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
        $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
        (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))