]> git.saurik.com Git - apt.git/blobdiff - debian/tests/run-tests
CMake: debian: Switch packaging over to CMake and dh 9
[apt.git] / debian / tests / run-tests
index 233c5a386b1f80790dd87810a38f85b9ffa16ddf..d2fa915b87abd99a24373a5f30e42ad92ae2301a 100644 (file)
@@ -2,17 +2,23 @@
 
 set -e
 
-# auto-package-test is very unhappy if stuff it writen to stderr
-exec 2> apt-stderr.log
-
 # we need the buildin webserver for the tests
 if [ ! -e environment.mak ]; then
-    ./configure
+    make startup
 fi
 make -C test/interactive-helper/
 
-# run against the installed apt
+# run tests against the installed apt, use "env -i" to ensure
+# the host env does not pollute our environment
+env -i \
+APT_INTEGRATION_TESTS_SOURCE_DIR=$(pwd) \
 APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
 APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
+APT_INTEGRATION_TESTS_INTERNAL_SOLVER=/usr/lib/apt/solvers/apt \
+APT_INTEGRATION_TESTS_DUMP_SOLVER=/usr/lib/apt/solvers/dump \
+APT_INTEGRATION_TESTS_INTERNAL_PLANNER=/usr/lib/apt/planners/apt \
 APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
-./test/integration/run-tests
+APT_INTEGRATION_TESTS_FTPARCHIVE_BIN_DIR=/usr/bin \
+APT_INTEGRATION_TESTS_LIBRARY_PATH=/dev/null/does/not/exist \
+./test/integration/run-tests -q